summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM.Reynolds2019-12-14 17:41:43 -0500
committerM.Reynolds2019-12-14 17:41:43 -0500
commit6bb2da94dd39a19364817edd6b2aeae2a2f56ca7 (patch)
tree13ad7d76df0a7255e2449b3e599dafdae7cf0032 /PKGBUILD
parent8cef0253ce5e786c11a77f24530b876c60128d69 (diff)
downloadaur-6bb2da94dd39a19364817edd6b2aeae2a2f56ca7.tar.gz
Update 3.2.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea96c2b39766..b3295858ca0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,33 @@
# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=thonny
-pkgver=3.2.1
+pkgver=3.2.4
pkgrel=1
pkgdesc="Python IDE for beginners."
arch=('any')
url="http://thonny.org"
license=('MIT')
-depends=('openssl' 'python' 'python-beautifulsoup4' 'python-docutils' 'mypy'
+depends=('openssl' 'python' 'python-beautifulsoup4' 'python-docutils' 'mypy' 'python-asttokens'
'python-astroid' 'python-pylint' 'python-pyserial' 'python-jedi' 'tcl' 'tk')
source=("https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver-x86_64.tar.gz")
-sha256sums=('e7c2ffa6172418273116e18b5b61e2c7c0462a46730916c8ef63bb7c6c5ad065')
+sha256sums=('9532547adc49961826f65a29b3bbaab3bc325ef884efcdc94ff5f07b6ea2ad7c')
package() {
cd "$srcdir"
# Correct install path for binary and icon file
- sed -i 's|$target_dir|/usr|' "$pkgname/templates/Thonny.desktop"
+ sed -i 's|$target_dir|/usr|' "$pkgname/templates/Thonny.desktop"
# Update launch script for the correct Python version
- # sed -i 's|3.6|3.7' "$pkgname/bin/thonny"
-
- install -Dm 644 "$pkgname/templates/Thonny.desktop" \
- "$pkgdir/usr/share/applications/thonny.desktop"
+ sed -i 's|3.7|3.8|' "$pkgname/bin/thonny"
- install -Dm 755 "$pkgname/bin/thonny" "$pkgdir/usr/bin/thonny"
-
- install -Dm 644 "$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 "$pkgname/templates/Thonny.desktop" "$pkgdir/usr/share/applications/thonny.desktop"
+ install -Dm 644 "$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 755 "$pkgname/bin/thonny" "$pkgdir/usr/bin/thonny"
# Install.py currently does not allow for setting root for creating a package
# Files must by copied manually for now in section below.
- install -d 644 "$pkgdir/usr/lib/python3.7/site-packages/thonny"
- cp -dr --no-preserve=ownership "$pkgname/lib/python3.7/site-packages/thonny" \
- "$pkgdir/usr/lib/python3.7/site-packages"
-}
+ install -d 644 "$pkgdir/usr/lib/python3.8/site-packages/thonny"
+ cp -dr --no-preserve=ownership "$pkgname/lib/python3.7/site-packages/thonny" "$pkgdir/usr/lib/python3.8/site-packages"
+} \ No newline at end of file