summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM.Reynolds2017-05-16 16:04:38 -0400
committerM.Reynolds2017-05-16 16:04:38 -0400
commit6f7d5d591a73fdeef82b2e2549b915c525e860d0 (patch)
tree8701c5b823af438eb5bf71119cd55b15031382db /PKGBUILD
parentc35f3c3f2ee539bb115859a98fb1c1bcdb39f9db (diff)
downloadaur-6f7d5d591a73fdeef82b2e2549b915c525e860d0.tar.gz
Update 2.1.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61b8d20e91f1..00a51b51ad9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=thonny
-pkgver=2.0.7
-pkgrel=2
+pkgver=2.1.6
+pkgrel=1
pkgdesc="Python IDE for beginners."
arch=('any')
url="http://thonny.cs.ut.ee/"
license=('MIT')
depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk')
source=("https://bitbucket.org/plas/$pkgname/downloads/$pkgname-$pkgver-x86_64.tar.gz")
-sha256sums=('d226a76bbb640ffa84589ad13bf32b9709fe1cb63101dd8805da4949dbd243b6')
+sha256sums=('79551da55306cd27cfec9fcef9424bc0e86e2617f31ad805e087edcf74200905')
package() {
cd "$srcdir"
- # Patch version number for python3.6
- sed -i 's|python3.5|python3.6|' "$pkgname/bin/thonny"
- sed -i 's|python3.5|python3.6|' "$pkgname/templates/Thonny.desktop"
-
- install -Dm 755 "$pkgname/bin/thonny" "$pkgdir/usr/bin/thonny"
-
+ # Correct install path for binary and icon file
sed -i 's|$target_dir|/usr|' "$pkgname/templates/Thonny.desktop"
+
install -Dm 644 "$pkgname/templates/Thonny.desktop" \
"$pkgdir/usr/share/applications/thonny.desktop"
+ install -Dm 755 "$pkgname/bin/thonny" "$pkgdir/usr/bin/thonny"
+
install -Dm 644 "$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# Install.py currently does not allow for setting root for creating a package
# Files must by copied manually for now in section below.
install -d 644 "$pkgdir/usr/lib/python3.6/site-packages/thonny"
- cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/thonny" \
+ cp -dr --no-preserve=ownership "$pkgname/lib/python3.6/site-packages/thonny" \
"$pkgdir/usr/lib/python3.6/site-packages"
- install -Dm 644 "$pkgname/lib/python3.5/site-packages/distro.py" \
+ install -Dm 644 "$pkgname/lib/python3.6/site-packages/distro.py" \
"$pkgdir/usr/lib/python3.6/site-packages/distro.py"
-
- install -d 644 "$pkgdir/usr/lib/python3.6/site-packages/tkinterhtml"
- cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/tkinterhtml" \
- "$pkgdir/usr/lib/python3.6/site-packages"
}