summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2022-08-25 22:03:38 -0300
committerTércio Martins2022-08-25 22:03:38 -0300
commitb825520adcec6986ae32de5c026fb3f6d6aa1ab3 (patch)
tree98c50829f7cfb45c7e3b6ffcb2b428c3cade9218 /PKGBUILD
parent00cf13362e20a963d878735a90032faecacdc8ce (diff)
downloadaur-b825520adcec6986ae32de5c026fb3f6d6aa1ab3.tar.gz
Update to version 4.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46894b6e1b31..408fd15b5794 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,27 @@
# Contributor: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=thonny
-pkgver=3.3.14
+pkgver=4.0.0
pkgrel=1
pkgdesc="Python IDE for beginners"
arch=('any')
url="https://thonny.org"
license=('MIT')
-depends=('hicolor-icon-theme' 'mypy' 'python-astroid' 'python-asttokens' 'python-docutils' 'python-jedi' \
- 'python-pip' 'python-pylint' 'python-pyserial' 'python-send2trash' 'python-setuptools' 'tk')
+depends=('hicolor-icon-theme' 'mypy' 'python-asttokens' 'python-docutils' 'python-jedi' 'python-pip' \
+ 'python-pylint' 'python-pyserial' 'python-send2trash' 'python-setuptools' 'python-wheel' 'tk')
optdepends=('python-birdseye: Debug support with Birdseye'
'python-pgzero: Run programs made with Pygame Zero')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('93898bd36276184ad736b73c58e78ffb69e2a9eca1cc4e915dd50c171c1f42df00182d8bb1315d2218705bc9a3b37e4256521469402bdafc599b86656e0d9121')
+sha512sums=('81a9c11108e9bd03940244ffc4e9f60990eccb8440838a01fff0b38bc37f1e15b63e1275aaefbcdcc2c0d817f74c0e72dfe79ad6a7c5da9ffc0deee8f5e69af0')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
_xdg_desktop_name=org.${pkgname}.${pkgname^}