summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGary Wang2023-03-18 00:39:12 +0800
committerGary Wang2023-03-18 00:39:12 +0800
commit6393fee7b74945bb0c5c2d096fbd8207a22f064a (patch)
tree21da672aae722d81c587a8e99184da24f6543579 /PKGBUILD
parent25a848b4a2dd345077a2f7bf6fba9e53b1782b14 (diff)
downloadaur-6393fee7b74945bb0c5c2d096fbd8207a22f064a.tar.gz
update PKGBUILD for git submodule update command
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7defd32df496..393fa1228864 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gary Wang <wzc782970009@gmail.com>
pkgname=thplayer-git
-pkgver=r29.4ba4371
+pkgver=r53.cf74d30
pkgrel=1
pkgdesc='TouHou BGM player for all platform.'
arch=('x86_64')
@@ -33,7 +33,7 @@ prepare() {
cd ${srcdir}/thplayer
git submodule init
git config submodule.thtk.url ${srcdir}/thtk
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build () {
@@ -48,5 +48,5 @@ package() {
install -D ./COPYING ${pkgdir}/usr/share/licenses/thplayer-git/LICENSE
install -D ./assets/thplayer.desktop ${pkgdir}/usr/share/applications/thplayer.desktop
install -D ./assets/thplayer.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/thplayer.svg
- install -D ./assets/thplayer.png ${pkgdir}/usr/share/icons/hicolor/256x256/apps/thplayer.png
+ install -D ./assets/256-thplayer.png ${pkgdir}/usr/share/icons/hicolor/256x256/apps/thplayer.png
}