summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTolga HOŞGÖR2015-06-09 03:27:32 +0300
committerTolga HOŞGÖR2015-06-09 03:28:39 +0300
commit1f13e5588bd7e9f0377bd46e2e5b35b1f5fd37c3 (patch)
tree44a3615ba892771e70f770c855b9b64dc611c534 /PKGBUILD
downloadaur-1f13e5588bd7e9f0377bd46e2e5b35b1f5fd37c3.tar.gz
initial commit
Signed-off-by: Tolga HOŞGÖR <fasdfasdas@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4014df9b1ec5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=threadpool11-git
+pkgdesc='A fast, lock-free, cross-platform C++11 thread pooling library that is aiming to be lightweight and simple.'
+pkgver=2.0.6.r3.g31e6849
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+pkgrel=1
+source=("$pkgname"'::git+https://github.com/tghosgor/threadpool11.git')
+arch=('any')
+url=('https://github.com/tghosgor/threadpool11')
+license=('LGPL3')
+makedepends=(
+ 'boost' # Boost.Lockfree is used, there is an internal copy if you do not have it installed but we want it to be recent for this.
+)
+sha512sums=('SKIP')
+options=('staticlibs')
+
+package() {
+ cd "$srcdir"/$pkgname
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr
+ make install
+}