summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwincak2018-02-26 20:18:52 +0200
committerwincak2018-02-26 20:18:52 +0200
commit0f198905aba2ef210165e6938e3f0fad066e5bb4 (patch)
tree371ae1a5c7ad7e655e503f5da8be50f830712879 /PKGBUILD
downloadaur-threshy-gui.tar.gz
First version. Should work.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d73544c043ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: wincak <wincak@seznam.cz>
+pkgname=threshy-gui
+pkgver=0.2
+pkgrel=0
+pkgdesc="Qt GUI for Threshy"
+arch=('x86_64')
+url="https://gitlab.com/wincak/threshy-gui"
+license=('GPL')
+depends=('threshy>=0.2' 'qt5-base>=5.9')
+install=
+source=("git+https://gitlab.com/wincak/threshy-gui.git#tag=v0.2")
+md5sums=('SKIP')
+
+prepare() {
+ # TODO
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+
+ qmake PREFIX=/usr
+
+ make
+}
+
+check() {
+ # TODO
+ cd "$pkgname"
+ #make -k check
+}
+
+package() {
+ cd "$pkgname"
+ make INSTALL_ROOT="$pkgdir/" install
+}