summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkaptoxic2016-04-29 12:40:04 -0400
committerkaptoxic2016-04-29 12:40:04 -0400
commit1edf00afaf89c810edbff094054e32a6351fff90 (patch)
tree26e6ef4807bdd7f9f02c720e7e04eaa116356e90 /PKGBUILD
parent547e29783256cdacab8d01355e3859027da1e5a1 (diff)
downloadaur-thrift-java.tar.gz
Update and fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 22 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5db8b5a08abf..daefc418a783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
+# Contributor: kaptoxic@yahoo.com
# Contributor: Jochen Schalanda <jochen+aur@schalanda.name>
# Contributor: Byron Clark <byron@theclarkfamily.name>
+
pkgname=thrift-java
-pkgver=0.9.1
+pkgver=0.9.3
pkgrel=1
pkgdesc="Java bindings for Thrift, a scalable cross-language services framework for IPC/RPC"
arch=(i686 x86_64)
url="http://thrift.apache.org/"
license=(APACHE)
-depends=(zlib libevent openssl java-runtime)
-makedepends=(automake autoconf libtool apache-ant java-environment)
+depends=(gcc-libs openssl java-runtime)
+makedepends=(automake libevent autoconf libtool apache-ant java-environment)
optdepends=(
- 'thrift-base: for the Thrift compiler'
- 'vim-thrift: for syntax highlighting in vim')
+ 'thrift: for the Thrift compiler and syntax highlighting in vim/emacs')
options=(!emptydirs !makeflags)
-source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz
+source=(https://github.com/apache/thrift/archive/$pkgver.tar.gz
maven-repo-path.patch)
-md5sums=('d2e46148f6e800a9492dbd848c66ab6e'
+md5sums=('193ecb66ff1cc4282e7625aa263622bf'
'bfcb3b12a8c07d5d0d9e96a7e712a74c')
build() {
@@ -26,6 +27,7 @@ build() {
# apache-ant is not installed in a normal path location
. /etc/profile.d/apache-ant.sh
+ ./bootstrap.sh
./configure --prefix=/usr \
--without-cpp \
--without-qt4 \
@@ -40,7 +42,19 @@ build() {
--without-ruby \
--without-haskell \
--without-go \
- --without-d
+ --without-d \
+ --without-haskell \
+ --without-php \
+ --without-ruby \
+ --without-python \
+ --without-erlang \
+ --without-perl \
+ --without-c_sharp \
+ --without-d \
+ --without-php \
+ --without-go \
+ --without-lua \
+ --without-nodejs
make
}