summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Kuc2020-12-12 17:52:33 +0000
committerMichael Kuc2020-12-12 17:52:33 +0000
commitf5882f0357a424ae37032feb17392164e626428a (patch)
treed74eb74d2e6ae64d5e67f498b0f14c73b6a1675c /PKGBUILD
downloadaur-f5882f0357a424ae37032feb17392164e626428a.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9da6175f9b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Kuc <michaelkuc6 at gmail dot com>
+_pkgname=thrill
+pkgname=${_pkgname}-git
+pkgver=12c5b59bc
+pkgrel=1
+pkgdesc="Thrill is an EXPERIMENTAL C++ framework for algorithmic distributed Big Data batch computations on a cluster of machines."
+arch=('x86_64')
+url="https://github.com/thrill/thrill"
+license=('BSD')
+depends=()
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+epoch=1
+source=("${_pkgname}::git+https://github.com/thrill/thrill.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build
+ cd build
+ cmake -DTHRILL_BUILD_TESTS=OFF ..
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/build"
+ make PREFIX=/usr DESTDIR="${pkgdir}/" install
+ install -m644 -D "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 -D "${srcdir}/${_pkgname}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}