summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor2020-07-21 15:25:43 -0300
committerVictor2020-07-21 15:25:43 -0300
commit72d306234104d4a48ba048519e4a4e6af87cc059 (patch)
tree84477815c8783febc93d0960cb87fcfc9cb67b09 /PKGBUILD
parentea02c47b04aed768df5cdaa5732f20b8c06db217 (diff)
downloadaur-72d306234104d4a48ba048519e4a4e6af87cc059.tar.gz
Updated dependency on cub (integrated as submodule)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dff46f176a23..c8386ef8bcc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=thrust
pkgname=thrust-git
-pkgver=1.9.4.28.g986d178b
+pkgver=1.9.10.40.gd9d7b510
pkgrel=1
pkgdesc='A C++ parallel programming library which resembles the C++ Standard Library'
arch=('any')
@@ -19,19 +19,29 @@ optdepends=(
'intel-tbb: for TBB backend'
)
-source=("git+https://github.com/thrust/${_pkgname}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/thrust/${_pkgname}.git"
+ "git+https://github.com/thrust/cub.git")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${_pkgname}"
git describe --always | sed -e 's|-|.|g'
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule init
+ git config submodule.cub.url "${srcdir}/cub"
+ git submodule update
+}
+
package() {
install -dm 755 "${pkgdir}/opt/${_pkgname}"
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
cp -r ${_pkgname} "${pkgdir}/opt/${_pkgname}/"
cp -r examples "${pkgdir}/opt/${_pkgname}/"
+ cp -rL cub "${pkgdir}/opt/${_pkgname}/"
}
# vim: ft=sh ts=2 sw=2 et