summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2017-11-19 00:55:17 -0500
committerTed Alff2017-11-19 00:55:17 -0500
commit8d38a20d80c00af22bce1d37ad618f262e4b947c (patch)
tree0f50e5de7e41bcda5c9d6a898cc40e86ded028ec /PKGBUILD
downloadaur-8d38a20d80c00af22bce1d37ad618f262e4b947c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..765f8188df93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=thunar-dropbox
+pkgname=${_pkgname}-git
+pkgver=0.2.1.r2.g61ba51b
+pkgrel=1
+pkgdesc="Plugin for thunar that adds context-menu items for dropbox."
+arch=('i686' 'x86_64')
+url="https://github.com/Maato/thunar-dropbox"
+license=('GPL3')
+depends=('thunar-git')
+makedepends=('python2' 'git')
+source=("${_pkgname}::git+https://github.com/Maato/thunar-dropbox"
+ 'thunarx-3-port.patch::https://github.com/twa022/thunar-dropbox/commit/2da13dc73c56cea4a1d3de19c4917467954f985d.patch')
+sha256sums=('SKIP'
+ 'ab12fdc792903a3e07fba3cd58c9553075a3bff672fcc45b561ccb7c5bb8e31c')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -uNp1 -r- -i ../thunarx-3-port.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python2 waf install --destdir="${pkgdir}"
+}