summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDominik Schwaiger2022-05-21 13:29:35 +0200
committerDominik Schwaiger2022-05-21 13:29:35 +0200
commita092e44d47e9508ecaea33520943b152eb221207 (patch)
tree3bececa195860e8a697279697de8bccb09bfbff1 /PKGBUILD
downloadaur-a092e44d47e9508ecaea33520943b152eb221207.tar.gz
v1.0 initial package release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b086cf9562ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dominik Schwaiger <mail@dominik-schwaiger.ch>
+pkgname=thunar-nextcloud-plugin
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc=" A plugin for sharing files via the Nextcloud client from within the Thunar file manager"
+arch=("x86_64")
+url="https://github.com/frederikmoellers/thunar-nextcloud-plugin"
+license=('GPL-3')
+groups=()
+depends=("thunar" "nextcloud-client" "gcc" "unzip" "gtk3")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/frederikmoellers/thunar-nextcloud-plugin/archive/3015ee5bce2db072a2eeaa158150af2d7c0bfba6.zip")
+noextract=()
+sha256sums=("d43e249fb9771a857dcca706a912cc631da7bbe259e5cdaac2a7eaa725ffda82")
+validpgpkeys=()
+
+package() {
+ unzip -f 3015ee5bce2db072a2eeaa158150af2d7c0bfba6.zip
+ cd thunar-nextcloud-plugin-3015ee5bce2db072a2eeaa158150af2d7c0bfba6
+ bash compile.sh
+ install -D thunar-nextcloud-plugin.so "$pkgdir"/usr/lib/thunarx-3/thunar-nextcloud-plugin.so
+}