summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-05-26 04:39:28 -0300
committerPablo Lezaeta Reyes2015-05-26 04:39:28 -0300
commit6d57970dafb4349ea2b174709248b0836a2587a1 (patch)
treeded30cb03691756302b9ce541e105e782504536c /PKGBUILD
downloadaur-6d57970dafb4349ea2b174709248b0836a2587a1.tar.gz
nilfs2
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c5f5034b7c07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pablo Lezaeta <prflr88 @ gmail . com> (Pony Provider)
+
+pkgname=thunar-nilfs2-plugin-git
+_pkgname=thunar-nilfs2-plugin
+pkgver=0.git4
+pkgrel=1
+pkgdesc="You can see a list of checkpoints created by NILFS2 in Thunar"
+arch=('i686' 'x86_64')
+url="https://github.com/kazuki/thunar-nilfs2-plugin"
+license=('GPL3')
+depends=('nilfs-utils')
+provides=('thunar-nilfs2-plugin')
+conflicts=('thunar-nilfs2-plugin' 'thunar-nilfs2-plugin-git')
+makedepends=('git' 'thunar' 'xfce4-dev-tools')
+source=("$_pkgname::git+https://github.com/jristz/thunar-nilfs2-plugin.git")
+md5sums=("SKIP")
+
+pkgver(){
+ cd $_pkgname
+ #echo "$(git describe --always --abbrev=0 ).git$(git rev-list --count HEAD | sed 's/-/./g' )"
+ echo "0.git$(git rev-list --count HEAD | sed 's/-/./g' )"
+}
+
+build(){
+ cd $srcdir/$_pkgname
+ ./autogen.sh --prefix=/usr --bindir=/usr/bin \
+ --sbindir=/usr/bin --libdir=/usr/lib \
+ --libexecdir=/usr/lib/$_pkgname
+ make
+}
+
+package(){
+ cd $srcdir/$_pkgname
+ make DESTDIR=$pkgdir sbindir=/usr/bin install
+}
+