summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeb Deligny2017-09-03 18:02:13 +0200
committerSeb Deligny2017-09-03 18:02:13 +0200
commit0c98d752e3dcd0a623522a6a15799e76f68c47ab (patch)
tree10e487badb58dba7718b076b2cf2272c69126dde /PKGBUILD
parent8d4820733c34b4ca2ca26359863f266586c59a6b (diff)
downloadaur-0c98d752e3dcd0a623522a6a15799e76f68c47ab.tar.gz
Updated to compile the master branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78b69313dca2..f0a9a866052f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: SpepS <dreamspepser at yahoo dot it>
# Contributor: vinz <vinz@archlinux.us>
# Contributor: Aurélien DESBRIÈRES <ice.cube@gmx.com>
-
+# Contributor: Daniel Jenssen <daerandin@gmail.com>
+
pkgname=thunar-shares-plugin
pkgver=0.2.0.git
-_gitcommit=053cc4e0dc484081def59769efbe3a544fe169bc
-pkgrel=2
+pkgrel=3
pkgdesc="Thunar plugin to quickly share a folder using Samba without requiring root access"
arch=('i686' 'x86_64')
url="http://goodies.xfce.org/projects/thunar-plugins/${pkgname}"
@@ -14,23 +14,20 @@ license=('GPL2' 'LGPL')
depends=('thunar' 'samba')
makedepends=('xfce4-dev-tools')
install="${pkgname}.install"
-source=("http://git.xfce.org/thunar-plugins/thunar-shares-plugin/snapshot/thunar-shares-plugin-${_gitcommit}.tar.bz2"
- "drop-thunar-vfs.patch::http://git.xfce.org/thunar-plugins/thunar-shares-plugin/patch/?id=3a89ca67b27d717b13fed7851fce3244f31fc94e")
-sha1sums=('a6c4ca62f34fc26bde7ec94f5fcc5d9b6593b282'
- '29a0e3c31e1e48008c781c3575915398ec9e502b')
-
+source=("https://git.xfce.org/thunar-plugins/thunar-shares-plugin/snapshot/thunar-shares-plugin-master.tar.bz2")
+sha1sums=('SKIP')
+
prepare() {
- cd "${srcdir}/${pkgname}-${_gitcommit}"
- patch -Np1 -i "${srcdir}/drop-thunar-vfs.patch"
+ cd "${srcdir}/${pkgname}-master"
}
-
+
build() {
- cd "${srcdir}/${pkgname}-${_gitcommit}"
+ cd "${srcdir}/${pkgname}-master"
./autogen.sh --prefix=/usr --enable-debug=no
make
}
-
+
package() {
- cd "${srcdir}/${pkgname}-${_gitcommit}"
+ cd "${srcdir}/${pkgname}-master"
make DESTDIR="${pkgdir}" install
-}
+} \ No newline at end of file