summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2017-09-06 11:34:00 +0200
committerChristian Muehlhaeuser2017-09-06 11:34:00 +0200
commit03c66a8999a70c1121c2c13acad0253b60c727a4 (patch)
tree773aa8e0962da39f2679f9a3fdc09b3c6fb775aa /PKGBUILD
downloadaur-03c66a8999a70c1121c2c13acad0253b60c727a4.tar.gz
Initial import of thunder, an interactive shell for BoltDB files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4264de8da8d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
+
+pkgname=thunder
+pkgver=0.1
+pkgrel=1
+pkgdesc="An interactive shell for BoltDB files"
+arch=('x86_64')
+url="https://github.com/muesli/thunder"
+license=('MIT')
+makedepends=('go')
+source=("https://github.com/muesli/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('fdb58026914f53c60dbe92e3c4c11e3e803ac2cc02833c80273febdc274c4468')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ GOPATH=`pwd` go get -d -v
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ GOPATH=`pwd` go build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ # Install binary
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ # Copy License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+