summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorqaz2019-04-19 01:01:46 +0800
committerqaz2019-04-19 01:01:46 +0800
commitc8839de57d9472db78eeaf48b287008d2458f3b4 (patch)
tree96050c454439a4b222083f675ba9d47285506ef3 /PKGBUILD
downloadaur-c8839de57d9472db78eeaf48b287008d2458f3b4.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb9203b16513
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: qaz <fkxxyz@163.com>
+# Contributor: qaz <fkxxyz@163.com>
+
+pkgname=thunder-mini
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="Xunlei Product Center provides free download services for the latest products of Xunlei."
+arch=("i686" "x86_64")
+url="https://dl.xunlei.com/"
+license=('custom')
+depends=('wine')
+source=(
+ "http://down.sandai.net/mini/ThunderMini_dl1.5.3.288.exe"
+ "license.html::https://www.xunlei.com/xieyi/xl9.html"
+ "file://run"
+)
+
+prepare() {
+ cd "${srcdir}"
+ 7z x -y ThunderMini_dl1.5.3.288.exe
+ rm ./Bin/UnInstallClean.exe
+}
+
+package() {
+
+ # Copy files
+ install -d "${pkgdir}/usr/share/$pkgname"
+ cp -r "$srcdir/"{Bin,bho,Skin} "${pkgdir}/usr/share/$pkgname/"
+ cp "$srcdir/\$WINDIR/system32/"* "${pkgdir}/usr/share/$pkgname/Bin/"
+ find "${pkgdir}/usr/share/$pkgname/" -type d -exec chmod 755 {} \;
+
+ # Run script
+ install -Dm755 run "${pkgdir}/usr/share/$pkgname/run"
+
+ # Install licenses
+ install -Dm644 "license.html" "${pkgdir}/usr/share/licenses/$pkgname/license.html"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('95118524fa7d7e457c7bed4abcb5bbfc'
+ '381254665d06cdd2c9493a8892e32bc5'
+ '3c57bb9d9375bf00c11230caaf12ed5f')
+ \ No newline at end of file