summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2019-09-07 15:31:49 +0200
committerFrederic Bezies2019-09-07 15:31:49 +0200
commitb6002cc70f64a7a6ecb32bbf1ef6923bfdf6fb35 (patch)
treebe9fd84588ea1819fa2e4795d1accfea09d75cb0 /PKGBUILD
parent9bc57efa34d2fea2539d072900e8b08f54bfa163 (diff)
downloadaur-b6002cc70f64a7a6ecb32bbf1ef6923bfdf6fb35.tar.gz
69.0b4 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD210
1 files changed, 55 insertions, 155 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2438f14e245d..c6374dd2025f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: Det <nimetonmaili g-mail>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Det <nimetonmaili g-mail>
# Based on [extra]'s thunderbird: https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/thunderbird
pkgname=thunderbird-beta
-pkgver=60.6
-ver=60.0b6
+_pkgname=thunderbird
+pkgver=69.0
+_pkgver=69.0b4
_major=${pkgver/[br]*}
_build=${pkgver/*rc}
pkgrel=1
@@ -11,183 +13,84 @@ pkgdesc="Standalone mail and news reader from mozilla.org - Bleeding edge versio
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/thunderbird/"
-depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
- nss sqlite ttf-font icu libvpx)
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
- autoconf2.13 cargo clang llvm)
-optdepends=('hunspell: Spell checking'
- 'hyphen: Hyphenation'
- 'libcanberra: Sound support')
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
+ nss hunspell sqlite ttf-font icu)
+makedepends=(unzip zip diffutils python python2 yasm nasm mesa imake libpulse inetutils xorg-server-xvfb autoconf2.13 rust clang llvm gtk2 cbindgen nodejs)
+optdepends=('libcanberra: sound support')
+provides=("thunderbird=$_pkgver")
+conflicts=('thunderbird-beta-bin')
options=(!emptydirs !makeflags)
install=$pkgname.install
-source=(https://ftp.mozilla.org/pub/thunderbird/releases/$ver/source/thunderbird-$ver.tar.xz
- https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/$pkgname.desktop
- https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/thunderbird-install-dir.patch
- https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/no-crmf.diff
- https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/fix-wifi-scanner.diff
-https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/firefox-52-disable-data-sharing-infobar.patch
-https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/firefox-52-disable-location.services.mozilla.com.patch
-https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/firefox-52-disable-telemetry.patch
-https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/fix2.patch
-https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/fix.patch
-https://raw.githubusercontent.com/bn0785ac/thunderbeta/master/p.patch
-)
-
-sha512sums=('2ff2ee81bdd41a4e7a24f1cf3a6a338d6b25ded3f3aa608063967e67c6a7eedf1b3bcd46f8c8a2c160de4f2e751ce1bf71a2339da032b17dc825b311a2df7477'
- 'e5649ddee3ca9cfdcf56652e9c8e6160d52c69d1439f9135b0c0d436ce61a25f17758afc0dd6cac3434c26234c584828eb07fdf9604797f7dd3f617ec194b79a'
- '33f5c73b18b078c49b97ebd526a8d07eb091deb223018068434cec0ff95e4ac64dbde70f1c2ccf46f833a17f898bb9a916357eebac05f39399f23a08f79149f7'
- '951667941520e66e7b6aad55619ec2b38364da58c5cf8a71775a3032921cfc0a8e5c7ba14e0df35588175f94a6b4785566d39177ff536ab9cefcbd19a03dc065'
- '1bd2804bea1fe8c85b602f8c5f8777f4ba470c9e767ad284cb3d0287c6d6e1b126e760738d7c671f38933ee3ec6b8931186df8e978995b5109797ae86dfdd85a'
- '38d8e4d96fb2324b27bc9518ef54db3c47a6fc6846342e58ced56898bbafc09562e8c483998bab573908b5019ed88611c4893f752de491236cda00945d1d156a'
- '45efc5fdbfd63d53763c1cfdb01647a38efedc8f8af8dacef95c73b06fb5e9030d1597d16bc8337f8fa52b9b6d060c8cb85387dd81e5157340746c17a81225e6'
- 'ba950af03a906918d0981e18c0c6e131d0ef2bfb890bedbc47215e82b354a34ade89de1655bd245e76301a08cd543a4522745da47d70939bfe8adeab51e60501'
- '71ccc1ab8c28c269d2dd52f474dcc59bdb48defc3f38efc2e0725c1581ab14497753a790dd17325b74545d22f99b7cbaa46d461cc8fe73898632bb69b4238b4f'
- 'e43c3d5862f752dfbb7df2774bf57f675ee088985055a2d7fa67a5e6de864db4b5a25034854e9bd82b060fbff7668887f88b34e15cf61eb4de54fc6b0b60076f'
- '192b99ca24bce0c516d85fdd5da4ded66bcfe64b4b86024d61052b5e18caf99b3c04b0f9196483e59b752cc5ac1bc14310d575a92b7243aaeac2eee02ce6acfb')
-
+source=(https://ftp.mozilla.org/pub/thunderbird/releases/$_pkgver/source/thunderbird-$_pkgver.source.tar.xz
+ 'thunderbird-beta.desktop')
+sha256sums=('586cd300f2bc7c2bdb7987be5d1f2542ef9e79f8b82f5a04a8c1e50f4dbdd326'
+ 'aef1484f9df38db75330c142edc46d73053acee8b959562bc9e765c235d83cbe')
# RC
-if [[ $_build = ? ]]; then
- source[0]="https://ftp.mozilla.org/pub/thunderbird/candidates/$_major-candidates/build$_build/source/thunderbird-$_major.source.tar.xz"
-fi
-
+#if [[ $_build = ? ]]; then
+# source[0]="https://ftp.mozilla.org/pub/thunderbird/candidates/$_major-candidates/build$_build/#source/thunderbird-$_major.source.tar.xz"
+#fi
prepare() {
- # Link Python2
- mkdir -p path
- ln -sf /usr/bin/python2 path/python
-
- cd thunderbird-$ver
-
- msg2 "thunderbird-install-dir.patch"
- patch -Np1 -i ../thunderbird-install-dir.patch
-
- msg2 "no-crmf.diff: https://bugzilla.mozilla.org/show_bug.cgi?id=1371991"
- patch -Np1 -i ../no-crmf.diff
-
-
-
-cd mozilla
-
-patch -Np1 -i ../../firefox-52-disable-data-sharing-infobar.patch
-patch -Np1 -i ../../firefox-52-disable-location.services.mozilla.com.patch
-patch -Np1 -i ../../firefox-52-disable-telemetry.patch
-
-cd ../
-
-
+
+cd $_pkgname-$pkgver
# mozconfig
cat >.mozconfig <<END
-ac_add_options --enable-application=mail
+
+ac_add_options --enable-application=comm/mail
ac_add_options --enable-calendar
-ac_add_options --prefix=/opt
-ac_add_options --libdir=/opt
+ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
-#ac_add_options --enable-rust
+ac_add_options --enable-linker=gold
+ac_add_options --enable-hardening
+ac_add_options --enable-optimize
+ac_add_options --disable-elf-hack
# Branding
-ac_add_options --with-branding=../mail/branding/nightly
-ac_add_options --enable-update-channel=nightly
+ac_add_options --with-branding=comm/mail/branding/nightly
+#ac_add_options --enable-update-channel=nightly
ac_add_options --with-distribution-id=org.archlinux
-# Keys
-
-
# System libraries
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-icu
-ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
-ac_add_options --with-system-libvpx
-ac_add_options --enable-system-hunspell
+ac_add_options --with-system-icu
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
-ac_add_options --enable-system-pixman
# Features
+ac_add_options --enable-alsa
+ac_add_options --disable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
-ac_add_options --enable-alsa
ac_add_options --disable-updater
-ac_add_options --disable-tests ###
-ac_add_options --disable-debug-symbols ###
-
-ac_add_options --disable-necko-wifi
-ac_add_options --disable-webspeech
-ac_add_options --disable-webrtc
-
+ac_add_options --disable-gconf
END
-msg2 'fixing dependency errors'
-
-
-patch -Np1 -i ../p.patch
-
-cd mozilla
-
-patch -Np1 -i ../../fix.patch
-patch -Np1 -i ../../fix2.patch
}
build() {
- cd thunderbird-$ver
-
- # _FORTIFY_SOURCE causes configure failures
- CPPFLAGS+=" -O2"
-
- # Hardening
- LDFLAGS+=" -Wl,-z,now"
-
- # Export build path
- export PATH="$srcdir/path:$PATH"
-
- # Do PGO
- #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
- # make -f client.mk build MOZ_PGO=1
-
- # Build
- msg2 "Running make -f client.mk build.."
- make -f client.mk build
+ cd $_pkgname-$pkgver
+ ./mach configure
+ ./mach build
}
package() {
- cd thunderbird-$ver
-
-msg2 'fixing upstream error'
-
-
-cd $srcdir/thunderbird-$ver
-
-cp -r mail/branding/nightly other-licenses/branding/thunderbird
+ cd $_pkgname-$pkgver
+ DESTDIR="$pkgdir" ./mach install
-msg2 'fixing upstream error 2'
-cd other-licenses/branding/thunderbird
-cp default16.png mailicon16.png
-cp default22.png mailicon22.png
-cp default24.png mailicon24.png
-cp default32.png mailicon32.png
-cp default48.png mailicon48.png
-cp default64.png mailicon64.png
-cp default128.png mailicon128.png
-cp default256.png mailicon256.png
-
-cd $srcdir/thunderbird-$pkgver
- # Install
- msg2 "Running make -f client.mk install.."
- make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
-
- # vendor.js
- _vendorjs="$pkgdir/opt/$pkgname/defaults/preferences/vendor.js"
+ _vendorjs="$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+pref("intl.locale.requested", "");
+
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
// Disable default mailer checking.
pref("mail.shell.checkDefaultMail", false);
@@ -210,32 +113,29 @@ app.distributor.channel=$pkgname
app.partner.archlinux=archlinux
END
- # Icons
- for i in 16 22 24 32 48 256; do
- install -Dm644 other-licenses/branding/thunderbird/mailicon$i.png \
+ for i in 16 22 24 32 48 64 128 256; do
+ install -Dm644 comm/mail/branding/thunderbird/default${i}.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done
+ install -Dm644 comm/mail/branding/thunderbird/TB-symbolic.svg \
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps/thunderbird-symbolic.svg"
install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/$pkgname.desktop"
# Use system-provided dictionaries
- rm -r "$pkgdir"/opt/$pkgname/dictionaries
- ln -Ts /usr/share/hunspell "$pkgdir/opt/$pkgname/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/opt/$pkgname/hyphenation"
+ ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh
-exec /opt/$pkgname/thunderbird "\$@"
+exec /usr/lib/$pkgname/thunderbird "\$@"
END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -srf "$pkgdir/usr/bin/$pkgname" \
- "$pkgdir/opt/$pkgname/thunderbird-bin"
-
- # Use system certificates
- ln -srf "$pkgdir/usr/lib/libnssckbi.so" \
- "$pkgdir/opt/$pkgname/libnssckbi.so"
+ "$pkgdir/usr/lib/$pkgname/thunderbird-bin"
}
+