summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2017-11-04 15:01:25 +0200
committerDet2017-11-04 15:01:25 +0200
commitbaf3afd92bdaec511a67b90c4051d03d8c2311b3 (patch)
tree505b75d5cd53459b27ac81f31fa8a967d8747e80 /PKGBUILD
parent4cc797a012f4588f56ec7d377558d055b95ca4e7 (diff)
downloadaur-baf3afd92bdaec511a67b90c4051d03d8c2311b3.tar.gz
Spell-check/hyphenation + certs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46c7e5c25f77..aa9a435e3087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-
# Maintainer: Det <nimetonmaili g-mail>
# Based on [extra]'s thunderbird: https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/thunderbird
@@ -12,10 +11,12 @@ arch=(i686 x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/thunderbird/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
- nss hunspell sqlite ttf-font icu libvpx)
+ nss sqlite ttf-font icu libvpx)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
autoconf2.13 cargo clang llvm)
-optdepends=('libcanberra: sound support')
+optdepends=('hunspell: Spell checking'
+ 'hyphen: Hyphenation'
+ 'libcanberra: Sound support')
options=(!emptydirs !makeflags)
install=$pkgname.install
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
@@ -191,5 +192,8 @@ END
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -srf "$pkgdir/usr/bin/$pkgname" \
"$pkgdir/opt/$pkgname/thunderbird-bin"
-}
+ # Use system certificates
+ ln -srf "$pkgdir/usr/lib/libnssckbi.so" \
+ "$pkgdir/opt/$pkgname/libnssckbi.so"
+}