summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEwout van Mansom2023-07-17 01:44:42 +0200
committerEwout van Mansom2023-07-17 01:44:42 +0200
commit162f9b535aaad7fbdff591afb469a56ccd81a116 (patch)
treec80b0a74330614c35f590754a7f487b12a65c098 /PKGBUILD
downloadaur-162f9b535aaad7fbdff591afb469a56ccd81a116.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3329c42428a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Ewout van Mansom <ewout@vanmansom.name>
+#
+# See INSTALL.md to setup thunderbird to use this theme when installed
+# in your system /usr/lib directory via pacman and this PKGBUILD.
+
+_pkgname=thunderbird-gnome-theme
+pkgname=thunderbird-gnome-theme-git
+pkgver=r14.083e2f6
+pkgrel=1
+pkgdesc='A GNOME theme for Firefox'
+arch=('any')
+url='https://github.com/rafaelmardojai/thunderbird-gnome-theme'
+license=('Unlicense')
+optdepends=('thunderbird: primary compatible browser'
+ 'librewolf: alternative compatible browser')
+makedepends=('git')
+install='thunderbird-gnome-theme-git.install'
+source=('thunderbird-gnome-theme::git+https://github.com/rafaelmardojai/thunderbird-gnome-theme.git'
+ 'INSTALL.md')
+sha256sums=('SKIP'
+ '8238c490e2fd24957de4d96f4e523d269ea3c0c9a01cebc61827147c35075d5c')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+
+prepare() {
+ cd "${_pkgname}"
+
+ # Remove unneeded files
+ rm -rf "${pkgdir}/usr/lib/${_pkgname}"/{scripts,LICENSE,README.md,screenshot.png}
+}
+
+package() {
+ cd "${_pkgname}"
+
+ # Install user.js script and theme
+ install -dm644 "${pkgdir}/usr/lib/${_pkgname}/"{configuration,theme}
+ cp -dr --preserve=mode,timestamp configuration "${pkgdir}/usr/lib/${_pkgname}"
+ cp -dr --preserve=mode,timestamp theme "${pkgdir}/usr/lib/${_pkgname}"
+
+ # Install docs & license
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" README.md
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" ${srcdir}/INSTALL.md
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" LICENSE
+}