summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexei Colin2023-09-10 15:35:49 -0400
committerAlexei Colin2023-09-10 15:36:26 -0400
commit18647373c02f64d544be64efab3ad5d7983b6bc7 (patch)
treef7069a90a7af8ac6c50157f1142e1832d7330887 /PKGBUILD
parent3f8bc8ca6b3c86820a7ed7f8ef5e7cbadfa319b0 (diff)
downloadaur-18647373c02f64d544be64efab3ad5d7983b6bc7.tar.gz
updat to 20.2.7.LTS
Remove 32-bit stuff: the install and the compiler are both 64-bit executables now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d807c12ad3f..4f0e49033db9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,18 @@
# Maintainer: Alexei Colin <ac at alexeicolin dot com>
pkgname=ti-cgt-arm
-pkgver=20.2.1.LTS
-_manifest_ver=20.2.0.LTS
+pkgver=20.2.7.LTS
pkgrel=2
pkgdesc="Texas Instruments Code Generation Tools (compiler) for ARM"
arch=('x86_64')
url="http://www.ti.com/tool/ARM-CGT"
license=('custom')
-# lib32-glibc needed for the installer
-makedepends=('lib32-glibc' 'lib32-fakeroot')
#optdepends=('ccstudio')
conflicts=('ccstudio') # current package ships with the toolchains
-_installer="ti_cgt_tms470_${pkgver}_linux_installer_x86.bin"
-source=("http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${pkgver}/${_installer}")
+_installer="ti_cgt_tms470_${pkgver}_linux-x64_installer.bin"
+source=("https://dr-download.ti.com/software-development/ide-configuration-compiler-or-debugger/MD-sDOoXkUcde/${pkgver}/${_installer}")
options=(!strip libtool staticlibs emptydirs !purge !zipman)
@@ -29,15 +26,13 @@ prepare() {
package() {
echo ">>> Running installer..."
- echo ">>> Errors about acl like below are harmless (please ignore):"
- echo ">>> dlsym(acl_get_fd): /usr/lib32/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd"
./${_installer} --mode unattended --prefix $pkgdir/${_ccsdir}/${_installdir}
# Match permissions to ccstudio package (see notes in ccstudio.install)
find $pkgdir/${_ccsdir} -type d -exec chmod 0775 {} \;
- install -D -m0644 $pkgdir/${_ccsdir}/${_installdir}/${pkgname}_${pkgver}/ARM_RTS_${_manifest_ver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
+ install -D -m0644 $pkgdir/${_ccsdir}/${_installdir}/${pkgname}_${pkgver}/ARM_RTS_${pkgver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
}
-sha256sums=('fda075c64a7a1367c78d6c7c908b15f4de023112f03a4b96291ba9cd03b35808')
+sha256sums=('697bc381ed00c52d7be19d67f1cdf651a3068ec7c38404edd696ee7f801fb3e8')