summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexei Colin2017-06-23 03:00:39 -0400
committerAlexei Colin2017-06-23 02:16:52 -0400
commite6f135b0942fcd8f1f1fe67896a96e34cd5f8eb9 (patch)
tree12e5a310af248829bb0d90c1e5d545874c29eed9 /PKGBUILD
parente2dd89e15ed4fc4a0522113858af1836db44f6c8 (diff)
downloadaur-e6f135b0942fcd8f1f1fe67896a96e34cd5f8eb9.tar.gz
match permission of dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11685b472bc8..77c45ac586eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,19 +40,25 @@ options=(!strip libtool staticlibs emptydirs !purge !zipman)
_ccsdir=ccstudio
_destdir=opt
_installdir=installdir
-_installpath=$_installdir/$_destdir/ccstudio/ccsv7/tools/compiler
+_installloc=$_ccsdir/ccsv7/tools/compiler
+_installpath=$_installdir/$_destdir/$_installloc
+_tooldir=${pkgname}_${pkgver}
-build() {
- cd $srcdir/${_archive}
+prepare() {
+ cd $srcdir
+ chmod +x ./${_installer}
+}
- echo ">>> Executing installer. You can monitor progress with:"
- echo ">>> tail -f ${srcdir}/${_installpath}/ccsv7/install_logs/*/ccs_setup_${pkgver}_install.log"
+build() {
+ cd $srcdir
- # Assuming the same problem exists as for ccstudio installer (see ccstudio/PKGBUILD for details)
+ # Calling from build to avoid fakeroot, assuming the same problem exists as
+ # for ccstudio installer (see ccstudio/PKGBUILD for details)
./${_installer} --mode unattended --prefix $srcdir/$_installpath
}
package() {
+
# Hardlink to avoid time and space overhead
cp -ral $srcdir/$_installdir/$_destdir $pkgdir/