summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2018-08-11 14:22:00 -0400
committerredfish2018-08-11 14:22:00 -0400
commit9c2ee48e9371d893486990b668edc62975e9d040 (patch)
treee74957b1d4c43eaff6b24aa5c3636e44d59ef040 /PKGBUILD
parentda8e55ca708a6dcb8d9becba123f7eb3450b95b2 (diff)
downloadaur-9c2ee48e9371d893486990b668edc62975e9d040.tar.gz
update to 18.1.3.LTS
Add suffix to package version, in order to match upstream. Add license. Also, switch to sha256sums.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abf7a2720bff..de166772031c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Alexei Colin <ac at alexeicolin dot com>
pkgname=ti-cgt-msp430
-pkgver=18.1.1
+pkgver=18.1.3.LTS
pkgrel=1
pkgdesc="Texas Instruments Code Generation Tools (compiler) for MSP430"
arch=('x86_64')
-url="http://software-dl.ti.com/codegen/non-esd/downloads/index.htm"
+url="http://software-dl.ti.com/codegen/non-esd/downloads/index.htm#MSP430"
#url="http://www.ti.com/tools-software/compilers/download.html"
license=('custom')
optdepends=('ccstudio')
-_fullver=${pkgver}.LTS
-_installer=ti_cgt_msp430_${_fullver}_linux_installer_x86.bin
-source=("${_installer}::http://software-dl.ti.com/codegen/esd/cgt_public_sw/MSP430/${_fullver}/${_installer}")
+_installer=ti_cgt_msp430_${pkgver}_linux_installer_x86.bin
+source=("http://downloads.ti.com/codegen/esd/cgt_public_sw/MSP430/${pkgver}/${_installer}")
-md5sums=('2de92040dda2d41bb394aa658c112027')
options=(!strip libtool staticlibs emptydirs !purge !zipman)
+_ccsver=8
_ccsdir=ccstudio
_destdir=opt
_installdir=installdir
-_installloc=$_ccsdir/ccsv7/tools/compiler
+_installloc=$_ccsdir/ccsv$_ccsver/tools/compiler
_installpath=$_installdir/$_destdir/$_installloc
_tooldir=${pkgname}_${pkgver}
@@ -46,4 +45,9 @@ package() {
# Match permissions to ccstudio package (see notes in ccstudio.install)
find $pkgdir/$_destdir/$_ccsdir -type d -exec chmod 0775 {} \;
+
+ # Version in filename is out of date upstream
+ install -D -m0644 $srcdir/${_installpath}/${pkgname}_${pkgver}/MSP430_RTS_18.1.0.LTS.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
}
+
+sha256sums=('1ba8c8e9f54d9b5f8e0cde472309cb5c3a249a93aac7e36936bae19d1a9a85ce')