summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo2016-03-02 16:16:20 +0100
committerDanilo2016-03-02 16:16:20 +0100
commitb3d507447534bce4e6214be4293d56fb7dab4dc6 (patch)
tree3f3a14b07a85338ab3a63d96191db3fd5c677bc0 /PKGBUILD
parent796e1f5f863ca567cc8f8df5113a1865201527ed (diff)
downloadaur-b3d507447534bce4e6214be4293d56fb7dab4dc6.tar.gz
Use python 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d2c02e85ddd..3850c4801002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=ti
pkgname=ti-git
pkgver=r137.39cfe91
-pkgrel=1
+pkgrel=2
pkgdesc="A simple command line time tracker"
arch=('any')
url="http://ti.sharats.me/"
license=('MIT')
groups=()
-depends=('python-yaml' 'python-colorama')
+depends=('python2' 'python2-yaml' 'python2-colorama')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -25,6 +25,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%}"
+ sed -i 's/env python$/env python2/' bin/ti
+}
+
package() {
cd "$srcdir/${pkgname%}"
mkdir -p $pkgdir/usr/local/bin