summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2017-06-28 22:16:50 +0200
committerNarrat2017-06-28 22:16:50 +0200
commit3e9874b2de730c74fedf29f1179e160e6be9ef93 (patch)
treecd270d3afc25cb65fe22f13485e5949b70d1c1b6 /PKGBUILD
parentbf748feda8893417ce30114bf348cb9a6fe5fdcb (diff)
downloadaur-3e9874b2de730c74fedf29f1179e160e6be9ef93.tar.gz
tibia: remove start-tibia patch
Suggested by TheAifam5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 721d021d177a..ee3ab038dd5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=tibia
pkgver=11.32.5246
-pkgrel=1
-pkgdesc="A fast-paced free massively multiplayer online role-playing game."
+pkgrel=2
+pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
url="http://www.tibia.com"
license=('custom')
@@ -11,19 +11,14 @@ depends=('glu' 'libgl' 'libice' 'libxext' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
- "${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php"
- "tibia-starter.patch")
+ "${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php")
sha256sums=('907421de4de759f424c00bd8c1fa836568ff2fc80b9a0ca792bef1876747cdae'
- '965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5'
- '5ea261b626e788eedebc677df9ca412e668a7ea9db0b88e362378330c2ff475f')
+ '965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5')
prepare() {
gendesk -f -n
html2text "${pkgname}-agreement.php" > LICENSE
-
- # Adjust start-tibia.sh
- patch -Np1 -i "tibia-starter.patch"
}
package() {
@@ -37,5 +32,5 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p "${pkgdir}/usr/bin"
- install -Dm755 ${pkgname}-${pkgver}/start-tibia.sh "${pkgdir}/usr/bin/tibia"
+ ln -s "${pkgdir}/opt/Tibia/start-tibia.sh" "${pkgdir}/usr/bin/tibia"
}