summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2018-10-17 20:38:57 +0200
committerNarrat2018-10-17 20:38:57 +0200
commitc2962ddda2769e481d17291377c3d056efd5136c (patch)
tree584c55bf8e9389d255fcd534b7afe3519be55cf2 /PKGBUILD
parente3d05e37f12fe6782c13cc7f455b913b64a31f62 (diff)
downloadaur-c2962ddda2769e481d17291377c3d056efd5136c.tar.gz
Tibia: update stuff
No version information anymore, starter script got renamed and patch files needed some adjustments. I really hate their way of packaging this...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60d4925dbf28..144e810f962f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ricardo Cabral <ricardo.arturo.cabral@gmail.com>
pkgname=tibia
-pkgver=11.58.6239
+pkgver=latest
pkgrel=1
pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
@@ -15,38 +15,33 @@ source=("${pkgname}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
"01_openssl102.patch"
"02_freetype.patch")
-sha256sums=('SKIP'
- '965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5'
- '3d55ac564bb2edc8fe7e826743a774b2191d29a1905bb35e9d9b26528c7a0fe6'
- '554748e5e81ab9c693d118d6e6e28408062cdd2a1efc3a1a60a4f13edbcc91a6')
+sha256sums=('47ae3dc80e892bf57c2729e507eecadf2ff73263eca46c5edc860b43b772ac4f'
+ '1200d3d5a77c8408a79a92c2fb4bdb5fa123b928aa036a32d2951e2459f0f7d9'
+ 'e9e6cdd4e2954ae0838dc427a92871bb9cacdacb0523598c60287a05f8568d1f'
+ '3cdf107369e4366aa5fc6d1b90ba0b41bd3d19abeb418fb85a693d74c3ece736')
prepare() {
gendesk -f -n
html2text "${pkgname}-agreement.php" > LICENSE
- # Patching
- cd -- $(find . -maxdepth 1 -type d -iname tibia-\* -print -quit)
+ cd Tibia
# Tibia relies on openssl 1.0.x
patch -Np0 -i "${srcdir}/01_openssl102.patch"
# Tibia relies on specific freetype version
patch -Np0 -i "${srcdir}/02_freetype.patch"
}
-pkgver() {
- find . -maxdepth 1 -type d -iname tibia-\* -print -quit | sed 's/\.\/tibia-\(.*\)/\1/'
-}
-
package() {
- mkdir -p "${pkgdir}/opt/Tibia"
- cp -drv --no-preserve=ownership ${pkgname}-${pkgver}/* "${pkgdir}/opt/Tibia"
+ mkdir -p "${pkgdir}/opt/"
+ cp -drv --no-preserve=ownership Tibia/ "${pkgdir}/opt/"
chmod -R 775 "${pkgdir}/opt/Tibia"
chgrp -R games "${pkgdir}/opt/Tibia"
install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 ${pkgname}-${pkgver}/tibia.ico -t "${pkgdir}/usr/share/pixmaps/"
+ install -Dm644 Tibia/tibia.ico -t "${pkgdir}/usr/share/pixmaps/"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p "${pkgdir}/usr/bin"
cd "${pkgdir}/usr/bin/"
- ln -s "../../opt/Tibia/start-tibia.sh" tibia
+ ln -s "../../opt/Tibia/start-tibia-launcher.sh" tibia
}