summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2016-09-23 03:17:35 +0200
committerNarrat2016-09-23 03:26:43 +0200
commitf58aeac7ba0173bcfe27769fcd06767430b15955 (patch)
tree9ddd79e787bc7fff6361778e37ef5dec29d36521 /PKGBUILD
parentd747c05e8201a7967393582729e75137c20781d1 (diff)
downloadaur-f58aeac7ba0173bcfe27769fcd06767430b15955.tar.gz
tibia: Update to complete new version 11
Unofficial 64bit build of the complete rewritten client. So there are quite some changes to the PKGBUILD. Do note, the depends line is currently cosmetic, as the tibia starting script uses the libs delivered with the package. It is intended to remove those from the package and rely on the system ones
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5db7638e122..5848359f5430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
# Maintainer: Ricardo Cabral <ricardo.arturo.cabral@gmail.com>
-_name="Tibia"
+
pkgname=tibia
-pkgver=1096
-pkgrel=2
+pkgver=11.00.3839
+pkgrel=1
pkgdesc="A fast-paced free massively multiplayer online role-playing game."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.tibia.com"
license=('custom')
-depends_i686=('glu' 'mesa')
-depends_x86_64=('lib32-glu' 'lib32-mesa')
+depends=('glu' 'libgl' 'libice' 'libxext' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
-source=("http://static.tibia.com/download/tibia${pkgver}.tgz"
- 'http://www.tibia.com/support/agreement.php'
- "tibia.sh")
+source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
+ 'http://www.tibia.com/support/agreement.php'
+ "tibia-starter.patch")
-sha256sums=('11bec465da38ae8e6d4d773c54142fa38b6f99207b3a9ce118917e31b32a6488'
+sha256sums=('2fa3eee6ae78d37acc85f921816b4015be6b96ad0de08a4383084cf2ea5fdcd9'
'fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34'
- '472f7516fe56b5a6270f0bda0069e59559cf6cbc0d9079a6607842a5ee1d1a7b')
+ 'e91691e36a9f6228ece4f3346f21bce892f61902658d99c4a80e70daf0841325')
prepare() {
gendesk -f -n
html2text agreement.php > LICENSE
+
+ # Adjust start-tibia.sh
+ patch -Np1 -i "tibia-starter.patch"
}
package() {
mkdir -p "${pkgdir}/opt/Tibia"
- cp -drv --no-preserve=ownership ./Tibia/ "${pkgdir}/opt/"
+ cp -drv --no-preserve=ownership ${pkgname}-${pkgver}/* "${pkgdir}/opt/Tibia"
install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 Tibia/Tibia.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+ install -Dm644 ${pkgname}-${pkgver}/tibia.ico -t "${pkgdir}/usr/share/pixmaps/"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p "${pkgdir}/usr/bin"
- install -Dm755 tibia.sh "${pkgdir}/usr/bin/tibia"
+ install -Dm755 ${pkgname}-${pkgver}/start-tibia.sh "${pkgdir}/usr/bin/tibia"
}