summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbegin-theadventure2023-10-10 16:46:01 +0200
committerbegin-theadventure2023-10-10 16:46:01 +0200
commit672ab1a9f7f5a7a689f79f81409d00be4449e1b0 (patch)
tree3665fb205a6525cddebc692b1d8746de2fb11f1b /PKGBUILD
downloadaur-ticketbooth.tar.gz
1.0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0fb958ae433
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=ticketbooth
+pkgver=1.0.3.1
+pkgrel=1
+pkgdesc='Keep track of your favorite shows'
+url="https://github.com/aleiepure/ticketbooth"
+arch=('x86_64' 'aarch64')
+license=('CCPL:0-1' 'LGPL3' 'GPL3-or-later')
+depends=('python-tmdbsimple' 'libadwaita')
+makedepends=('blueprint-compiler' 'git' 'meson')
+checkdepends=('appstream-glib')
+source=("git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlog
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}