summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorokonek2018-04-06 21:33:26 +0000
committerokonek2018-04-06 21:33:26 +0000
commit54fa47d5589e82cefaa48dd1c9a26898266d3e35 (patch)
treed350ccb6dc659b22a709413e880d19fcc29c596d /PKGBUILD
downloadaur-54fa47d5589e82cefaa48dd1c9a26898266d3e35.tar.gz
First commit version 1.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e24c5c1f1ef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jan OkoĊ„ski <jandominikokonski@gmail.com>
+
+pkgname=tidal-cli-client # All lowercase
+_pkgname=${pkgname#nodejs-}
+pkgver=1.4.2
+pkgrel=1
+arch=(any)
+license=(MIT)
+depends=('nodejs' 'npm' 'mpv' 'w3m')
+optdepends=()
+source=(http://registry.npmjs.org/tidal-cli-client/-/tidal-cli-client-$pkgver.tgz)
+noextract=($_pkgname-$pkgver.tgz)
+sha1sums=(d37aca22094a39cffdb517e1b03708126a533776)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_pkgname@$_pkgver
+}