summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2020-02-19 14:47:52 +0800
committerAllen Zhong2020-02-19 14:47:52 +0800
commit2849fe99104ff134f34175557eb71aab3a8e7862 (patch)
treea66daba3f2d892e4a170c46a48bd3b44422814fa /PKGBUILD
parent104a06354c036ab470b0f326788d967201d90d11 (diff)
downloadaur-2849fe99104ff134f34175557eb71aab3a8e7862.tar.gz
add -trimpath build flag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57f05a5fc8fb..1ad36ae3b2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Maintainer: Allen Zhong <zhongbenli@pingcap.com>
pkgname=tidb
pkgver=3.0.9
-pkgrel=1
+pkgrel=2
pkgdesc='A distributed HTAP database compatible with the MySQL protocol'
-makedepends=('go' 'make' 'git')
+makedepends=('go' 'make')
arch=('x86_64')
url='https://github.com/pingcap/tidb'
license=('Apache')
@@ -40,8 +40,9 @@ build() {
# Remove all git operations.
sed -i '/(shell git /d' Makefile
_LDFLAGS="-X github.com/pingcap/parser/mysql.TiDBReleaseVersion=$pkgver -X $_gopkgname/util/printer.TiDBGitHash=v$pkgver -X $_gopkgname/util/printer.TiDBGitBranch=release"
+ _BUILD_FLAG="-trimpath"
- LDFLAGS=$_LDFLAGS make server
+ BUILD_FLAG=$_BUILD_FLAG LDFLAGS=$_LDFLAGS make server
}
package() {