summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Parente Lima2020-08-09 01:34:58 -0300
committerHugo Parente Lima2020-08-09 01:35:13 -0300
commitcc2256945daeb9c364c55a15f76bc7fe20e7dc69 (patch)
tree00627233d2294159528c6e90b21738b4147b6de1 /PKGBUILD
downloadaur-cc2256945daeb9c364c55a15f76bc7fe20e7dc69.tar.gz
Release 0.1.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b375eecd1de8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Hugo Parente Lima <hugo.pl@gmail.com>
+
+pkgname=tijolo
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Lightweight, keyboard-oriented IDE for the masses"
+arch=("x86_64")
+conflicts=("tijolo-git")
+url="https://github.com/hugopl/tijolo"
+license=("MIT")
+depends=("gc" "libevent" "pcre" "gtksourceview4" "nerd-fonts-jetbrains-mono" "libgit2")
+makedepends=("git" "crystal>=0.35.1" "shards>=0.11.0")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hugopl/tijolo/archive/v${pkgver}.tar.gz")
+sha256sums=('c5f978c4fcce99bc97af58fb634f6699102b2eddd2d3816adaaeb315c863c9c8')
+
+build() {
+ cd "$srcdir/tijolo-$pkgver"
+ make
+}
+
+check() {
+ # Can't check anything, since tests needs tijolo own project repo to execute.
+ true
+}
+
+package() {
+ cd "$srcdir/tijolo-$pkgver"
+ make install DESTDIR="${pkgdir}/usr"
+}