summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-11-11 00:53:31 +0100
committerhaawda2017-11-11 00:53:31 +0100
commit5598119856c196bbe38144255449cbe985fdc813 (patch)
tree32d35decafccbe6f0b31474a97402e7041974169 /PKGBUILD
parent263a245d6c2286a1833041c229f45a33bae497ac (diff)
downloadaur-5598119856c196bbe38144255449cbe985fdc813.tar.gz
rewrite
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae1c1bb96796..f554fb294b89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,28 @@
-# Maintainer: Alex Merry <dev@randomguy3.me.uk>
+# Contributor: Alex Merry <dev@randomguy3.me.uk>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=tikzit
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library"
arch=('i686' 'x86_64')
-url="http://tikzit.github.io"
+url="https://github.com/tikzit/tikzit.git"
license=('GPL2')
depends=('gnustep-base>=1.18.0' 'gtk2>=2.18.0'
'poppler-glib>=0.10' 'desktop-file-utils')
makedepends=('gcc-objc>=4.6.0' 'automake' 'autoconf' 'flex' 'bison')
optdepends=('texlive-core: previews')
-install="tikzit.install"
-source=(https://github.com/$pkgname/$pkgname/archive/v${pkgver}.tar.gz)
-md5sums=('ca71f1f862136f10965323400be4f34f')
+source=(tikzit-$pkgver.zip::https://github.com/$pkgname/$pkgname/archive/master.zip)
+sha256sums=('b0756500fae0029df41cbd6105c48c90a1f60231a9cb5558d73cd319464669ab')
build() {
- source /etc/profile.d/GNUstep.sh
- cd "$srcdir/$pkgname-$pkgver/tikzit"
+ cd $pkgname-master/tikzit
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
- make -j1 || return 1
+ make -j1
}
package() {
- source /etc/profile.d/GNUstep.sh
- cd "$srcdir/$pkgname-$pkgver/tikzit"
- make -j1 "DESTDIR=$pkgdir" install || return 1
+ cd $pkgname-master/tikzit
+ make -j1 "DESTDIR=$pkgdir" install
}
-
-# vim: set ts=2 sw=2 et: