summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-06-27 19:37:40 +0100
committerHans-Nikolai Viessmann2019-06-27 19:37:40 +0100
commite4fc8622ffcff9e45b57013ec462d3a9778e343f (patch)
treef4cbc3bd38112e9e2fced39b2c3c9c9c33cee427 /PKGBUILD
parent1b0391a3e45afcd98e876757b7bb9e7fd0a14eae (diff)
downloadaur-e4fc8622ffcff9e45b57013ec462d3a9778e343f.tar.gz
minor fix to depends
Also fixed up packaging function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ff04bd74bfb..960d98dfdd89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: max_meyer
+# Contributor: Hans-Nikolai Viessmann <hans AT viess.mn>
+# Contributor: max_meyer
# Contributor: popsch
# Based on original tikzit-aur-package made by pippin
pkgname=tikzit
pkgver=2.1.4
-pkgrel=2
+pkgrel=3
pkgdesc="Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library"
arch=('i686' 'x86_64')
url="https://tikzit.github.io/"
license=('GPL2')
-depends=('qt5-base')
-makedepends=('poppler-qt5')
+depends=('qt5-base' 'poppler-qt5')
optdepends=('texlive-core: previews')
source=("$pkgname-$pkgver.tar.gz::https://github.com/tikzit/tikzit/archive/v$pkgver.tar.gz")
sha256sums=('14443ab430ff20e5c3b185a704932858afb3d776aa9b3a54e1b9898d5b9c13a8')
@@ -19,13 +19,12 @@ sha256sums=('14443ab430ff20e5c3b185a704932858afb3d776aa9b3a54e1b9898d5b9c13a8')
build() {
cd $pkgname-$pkgver
qmake PREFIX=/usr \
- QMAKE_CFLAGS="${CFLAGS}" \
- QMAKE_CXXFLAGS="${CXXFLAGS}" tikzit.pro
- make -j1
+ QMAKE_CFLAGS="${CFLAGS}" \
+ QMAKE_CXXFLAGS="${CXXFLAGS}" -r
make
}
package() {
cd $pkgname-$pkgver
- install -Dm755 tikzit "$pkgdir"/usr/bin/tikzit
+ make INSTALL_ROOT="$pkgdir" install
}