summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:30:41 +0200
committerJorge Barroso2015-06-15 21:30:41 +0200
commit6b50824fd90c10d8e1c3201a3cd6386c27dfa321 (patch)
treeadca12e356b8ddf659a001537b2b3b48aab30d2d /PKGBUILD
downloadaur-6b50824fd90c10d8e1c3201a3cd6386c27dfa321.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..882c6f17bdd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+#! /bin/sh
+# Contributor: DerFlob <derflob at derflob dot de>
+# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+
+pkgname=tilda-git
+_gitname=tilda
+pkgver=5a6496c
+pkgrel=1
+pkgdesc="Linux terminal based on classic terminals from first person shooter games"
+arch=('i686' 'x86_64')
+url="https://github.com/lanoxx/tilda"
+license=('GPL')
+depends=('gtk3' 'vte290' 'glib2' 'confuse' 'libglade')
+makedepends=('git')
+provides=('tilda')
+conflicts=('tilda')
+
+source=('git://github.com/lanoxx/tilda.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir/" install
+ sed -i 's|applications/tilda.png|pixmaps/tilda.png|' "$pkgdir/usr/share/applications/tilda.desktop"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file