summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Morr2018-09-06 11:35:27 +0200
committerSebastian Morr2018-09-06 11:35:27 +0200
commit0f225265c59e10324d49ddb3840696326922feea (patch)
tree56c0a631e139cfd3d96760fe85a5f2702a66b5a6 /PKGBUILD
downloadaur-timelens.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edab89bb1264
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sebastian Morr <sebastian@morr.cc>
+
+pkgname=timelens
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Creates visual timelines from video files, to visualize color development. Inspired by the moviebarcode tumblr."
+arch=('i686' 'x86_64')
+url="https://github.com/timelens/timelens"
+license=('GPL')
+provides=('timelens')
+conflicts=('timelens')
+depends=('gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav')
+makedepends=('git' 'rust')
+source=(https://github.com/timelens/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('81612aca6ccb386c808cda4ffe0af7a7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/timelens" "$pkgdir/usr/bin/timelens"
+}