summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPyntux2021-02-27 23:27:59 +0100
committerPyntux2021-02-27 23:27:59 +0100
commit63b2e38eaa41ce81ba4ac798896e1f7e62aaa007 (patch)
tree2e1060577c32f2d9f554261f3adad03b866bdc76 /PKGBUILD
downloadaur-63b2e38eaa41ce81ba4ac798896e1f7e62aaa007.tar.gz
First stable release, version 0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8335cd20e49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Pyntux <pyntux@gmail.com>
+
+pkgname=timerdown
+pkgver=0.1
+pkgrel=1
+pkgdesc="A simple python & pyQT5 app to turn off your Linux PC in "X" minutes or "X" hours, or at specified time."
+url="https://github.com/Pyntux/TimerDown"
+arch=('any')
+license=('GPL3')
+depends=('python-pyqt5')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("$pkgname::git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ cd "${pkgname%-*}"
+ install -d "$pkgdir"/usr/{bin,share/timerdown,share/applications}
+ cp -r {resources.py,timerdown.ico,TimerDown.py} "$pkgdir/usr/share/${pkgname%-*}"
+ cp -r {TimerDown.desktop,} "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
+ echo "#!/bin/sh
+python /usr/share/timerdown/TimerDown.py" >> "$pkgdir/usr/bin/${pkgname%-*}"
+ chmod +x "$pkgdir/usr/bin/${pkgname%-*}"
+}