summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2020-07-30 10:49:26 -0300
committerRafael Fontenelle2020-07-30 10:49:26 -0300
commit4b8a60bee7695fff170ddfba5d6ce8f88cd20dbb (patch)
treee7f39933daae0f78f7606008ca2cffe75d7c4082 /PKGBUILD
downloadaur-4b8a60bee7695fff170ddfba5d6ce8f88cd20dbb.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cf3c2f21a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+pkgname=timetrack
+pkgver=1.2.2.r0.gf273606
+pkgrel=1
+pkgdesc="Simple time-tracking app for GNOME"
+arch=('any')
+url="https://gitlab.gnome.org/danigm/timetrack"
+license=('GPL3')
+depends=(gobject-introspection libhandy python-timeago)
+makedepends=(meson git)
+_commit=f273606928ed32bfb5b0994f35dce9efb491241c # version 1.2.2
+source=("git+$url#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}