summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHaochen Tong2021-06-28 19:45:35 +0800
committerHaochen Tong2021-06-28 19:45:35 +0800
commit03c7c94cb3a0f9d98eb97400662c3ae1266446fe (patch)
treee2bdb0eb74385b0174122c93cdce542aee5a958b /PKGBUILD
parent59ffa4e25f6474acb82886b8c353858038462c7c (diff)
downloadaur-tinc-pre.tar.gz
upgpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25863021b396..2cd1447ec549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: hexchain <i at hexchain dot org>
pkgname=tinc-pre
-pkgver=1.1pre17
-pkgrel=2
+pkgver=1.1pre18
+pkgrel=1
pkgdesc="VPN (Virtual Private Network) daemon (Pre-release)"
arch=(i686 x86_64 armv7h armv6h)
url="http://www.tinc-vpn.org/"
@@ -12,17 +12,11 @@ makedepends=('git' 'autoconf')
optdepends=('python2' 'wxpython: gui support')
provides=('tinc-pre' 'tinc-pre-systemd')
conflicts=('tinc' 'tinc-pre-systemd')
-source=("git+https://github.com/gsliepen/tinc.git#tag=release-$pkgver")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/gsliepen/tinc/archive/refs/tags/release-$pkgver.tar.gz")
+sha256sums=('bd2d010a1bdeb1dd767f6fbc769fce2a2169119fb3d177df928c27d1f20b5775')
build() {
- cd "$srcdir/tinc"
-
- export GIT_COMMITTER_NAME="Builder" GIT_COMMITTER_EMAIL="builder@builder.local"
- git cherry-pick 2b0aeec02d64bb4724da9ff1dbc19b7d35d7c904
- git cherry-pick f8190b7233871b5b47c3fc8846731d1bbdef78a5
- git cherry-pick f3ba50ed3d14749b7c1ef100d2a49ac30d3b3853
- unset GIT_COMMITTER_EMAIL GIT_COMMITTER_NAME
+ cd "$srcdir/tinc-release-$pkgver"
autoreconf -fsi
./configure \
@@ -36,7 +30,7 @@ build() {
}
package() {
- cd "$srcdir/tinc"
+ cd "$srcdir/tinc-release-$pkgver"
make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir/etc/tinc/"