summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHaochen Tong2017-09-05 11:49:14 +0800
committerHaochen Tong2017-09-05 11:49:14 +0800
commit9fcf359e372c4abb8b055dc87a030d8b246f605a (patch)
treec2aefb1d9641e77c3a5f8f37af95f120edcafc12 /PKGBUILD
parent9fd6a2d3d1fac828079e5644bc44639eb51926db (diff)
downloadaur-9fcf359e372c4abb8b055dc87a030d8b246f605a.tar.gz
upgpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f7ad1d601a9..8d4cbef09a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Hexchain Tong <i at hexchain dot org>
pkgname=tinc-pre
-pkgver=1.1pre14
-pkgrel=3
+pkgver=1.1pre15
+pkgrel=1
pkgdesc="VPN (Virtual Private Network) daemon (Pre-release)"
-arch=(i686 x86_64 armv7h)
+arch=(i686 x86_64 armv7h armv6h)
url="http://www.tinc-vpn.org/"
license=('GPL')
-depends=('lzo' 'zlib' 'openssl-1.0' 'miniupnpc')
+depends=('lzo' 'zlib' 'openssl' 'miniupnpc')
makedepends=('git' 'autoconf')
optdepends=('python2' 'wxpython: gui support')
provides=('tinc-pre' 'tinc-pre-systemd')
@@ -26,9 +26,6 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--with-systemd=/usr/lib/systemd/system \
- --with-openssl=/usr/lib/openssl-1.0 \
- --with-openssl-include=/usr/include/openssl-1.0 \
- --with-openssl-lib=/usr/lib/openssl-1.0 \
--enable-miniupnpc
make
}
@@ -41,6 +38,4 @@ package() {
mkdir -p "$pkgdir/usr/share/doc/tinc-pre/"
cp -rv --no-preserve='ownership' "$srcdir/tinc/doc/sample-config/" "$pkgdir/usr/share/doc/tinc-pre/"
install -Dm644 "$srcdir/tinc/bash_completion.d/tinc" -t "$pkgdir/usr/share/bash-completion/completions/"
-
- # install -Dm644 "$srcdir/tinc/systemd/tinc@.service" -t "$pkgdir/usr/lib/systemd/system/"
}