summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBlack_Codec2015-09-02 21:38:09 +0200
committerBlack_Codec2015-09-02 21:38:09 +0200
commit2a788d4371a64fac234da2a2ec67ed45ef6d5038 (patch)
tree50b6308d96b78e545592cffaf23533c280736be5 /PKGBUILD
parent9368f666b7dfc7923fce69f32e6efe05a50d0545 (diff)
downloadaur-2a788d4371a64fac234da2a2ec67ed45ef6d5038.tar.gz
Used the wiki form for pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cd9c7267e3a..6e9099e2ad54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=tint2-git
_pkgname=tint2
-pkgrel=2
-pkgver=0.12.33.754918
+pkgrel=1
+pkgver=v0.12.1.r44.g1f7f197
pkgdesc="Git official release"
arch=('i686' 'x86_64')
url="https://gitlab.com/o9000/tint2"
@@ -18,7 +18,10 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --long | sed 's/[[:alpha:]]//g;s/-/./g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {