summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-07 12:28:10 -0300
committerDaniel Bermond2017-05-07 12:28:10 -0300
commit9d34f7eb9677131433448a691554a04742072867 (patch)
tree273661fae7a32595c1c6ec7e7331b181904b9196 /PKGBUILD
parent13e58a184e41da4f98407701d1f0d8cc8c24e2b6 (diff)
downloadaur-9d34f7eb9677131433448a691554a04742072867.tar.gz
Removed unnecessary makedepends. Cleaner build().
tiny-dnn is a header only library, so there is nothing to build. The previously allocated makedepends and cmake library/dependency options are for making the tests. Since we are not building the tests we can remove all the test stuff from makedepends and from cmake command.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 2 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7deb86783dc..2ac42de418a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
pkgname=tiny-dnn-git
-pkgver=1.0.0a3.r73.gb89239c
-pkgrel=2
+pkgver=1.0.0a3.r140.g77901b97
+pkgrel=1
pkgdesc="A C++11 implementation of deep learning for limited computational resource, embedded systems and IoT devices (git version)"
arch=('any')
url="https://github.com/tiny-dnn/tiny-dnn"
@@ -23,39 +23,15 @@ pkgver() {
build() {
cd "${pkgname}"
- # set CPU options
- if [ "$CARCH" = "x86_64" ]
- then
- # get CPU flags (contains supported CPU instruction sets)
- _cpuflags="$(grep -m1 'flags' /proc/cpuinfo | sed 's/^flags[[:space:]]*:[[:space:]]//')"
-
- # check if optional instructions are supported by the CPU
- { printf "%s" "$_cpuflags" | grep -q 'avx' && _avx="-DUSE_AVX:BOOL=ON" ; } || _avx="-DUSE_AVX:BOOL=OFF"
- { printf "%s" "$_cpuflags" | grep -q 'avx2' && _avx2="-DUSE_AVX2:BOOL=ON" ; } || _avx2="-DUSE_AVX2:BOOL=OFF"
-
- _cpuopts="-DUSE_SSE:BOOL=ON ${_avx} ${_avx2}"
- else
- _cpuopts="-DUSE_SSE:BOOL=OFF -DUSE_AVX:BOOL=OFF -DUSE_AVX2:BOOL=OFF"
- fi
-
cmake \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_COLOR_MAKEFILE:BOOL=ON \
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
- -DUSE_TBB=ON \
- -DUSE_OMP:BOOL=OFF \
- $_cpuopts \
- -DUSE_DOUBLE:BOOL=ON \
- -DUSE_NNPACK:BOOL=OFF \
- -DUSE_OPENCL:BOOL=ON \
- -DUSE_LIBDNN:BOOL=OFF \
- -DUSE_SERIALIZER:BOOL=ON \
-DBUILD_TESTS:BOOL=OFF \
-DBUILD_EXAMPLES:BOOL=OFF \
-DBUILD_DOCS:BOOL=OFF \
-Wno-dev \
.
- make
}
package() {