summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzhongxiong2022-06-29 12:21:31 +0800
committerzhongxiong2022-06-29 12:21:31 +0800
commit41e4ac69b5dbd68d10133ec3de8e0818fcf2766a (patch)
tree919b7e475a18fbc4c00acd764aa3886a88ae4b0e /PKGBUILD
downloadaur-41e4ac69b5dbd68d10133ec3de8e0818fcf2766a.tar.gz
Create repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b29c8c81d87b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: shilka<shilkazx[AT]gmail.com>
+
+
+pkgname=tinyb
+pkgver=0.5.1
+pkgrel=1
+epoch=
+pkgdesc="Intel Tiny Bluetooth LE Library"
+arch=(x86_64)
+url="https://github.com/intel-iot-devkit/tinyb"
+license=('MIT')
+groups=()
+depends=('bluez' 'java-environment>=1.8' 'java-environment<9')
+makedepends=("cmake")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/intel-iot-devkit/$pkgname/archive/v$pkgver.tar.gz")
+noextract=()
+sha256sums=("1d27b5f3b05c5b7a9f29f3d717164162607aa94b8e15ba2a9aaa3884908a2da1")
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake -DBUILDJAVA=ON -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" ..
+ make
+}
+package() {
+ cd "$pkgname-$pkgver"
+ cd build
+ make install
+}
+