summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:33:59 +0200
committerM0Rf302015-06-17 16:33:59 +0200
commitca06151153ee12a59d72f6f3a046602f12e0b0d1 (patch)
tree3d7671477aad4dd6e4dd4c7a50471cfb247186ac /PKGBUILD
downloadaur-ca06151153ee12a59d72f6f3a046602f12e0b0d1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c91b754cf6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: M0Rf30
+
+pkgname=tinycamd-svn
+pkgver=46
+pkgrel=1
+pkgdesc="A small webcam daemon for Video4Linux2 devices"
+arch=('i686' 'x86_64')
+url="https://tinycamd.googlecode.com"
+license=('BSD')
+depends=('libjpeg-turbo')
+makedepends=('subversion')
+source=("tinycamd::svn+http://tinycamd.googlecode.com/svn/trunk/")
+
+pkgver() {
+ cd tinycamd
+ svnversion | tr -d [A-z]
+}
+
+build() {
+ cd tinycamd
+ make CFLAGS="-Wall -O2 -MMD $(CFLAGS) $(COPTS)"
+}
+
+package() {
+ cd tinycamd
+ make DESTDIR=$pkgdir install
+}
+
+md5sums=('SKIP')