summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiancarlo Razzolini2016-08-15 16:21:57 -0300
committerGiancarlo Razzolini2016-08-15 16:21:57 -0300
commit5d6d1ea6f44e98e30d5e9aec5f5ee44a21b96252 (patch)
tree0819cedfa535a74e698f9e587dc8787aa1dc762b /PKGBUILD
downloadaur-5d6d1ea6f44e98e30d5e9aec5f5ee44a21b96252.tar.gz
* Commit of release version 0.1 of tinyssh-convert.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33d0ab8e3bb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Giancarlo Razzolini <grazzolini@gmail.com>
+pkgname=tinyssh-convert
+pkgver=0.1
+pkgrel=1
+pkgdesc="converter for ed25519 keys from OpenSSH to TinySSH format"
+arch=('x86_64' 'i686')
+url="https://github.com/ansemjo/tinyssh-convert"
+license=('MIT')
+makedepends=('autoconf')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('d592bf1981dc4074912a6fec3e55ab5fbef1f61f1bfcdaf147ecb640e95b220df3bbedd55e8cf764ec37ba820eccd36621c7a73e2b07ba8557ea74a7f417802e')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./build.sh
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 ${pkgname} $pkgdir/usr/bin/${pkgname}
+}