summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuan A. Rubio2019-01-19 19:50:29 +0000
committerJuan A. Rubio2019-01-19 19:50:29 +0000
commit0b039e6de711c80e0a71c4933c176eec5abf2777 (patch)
tree4fa9a1febba42a10cd109ce60c987b06908dc32c /PKGBUILD
parent2c045618e5170b9635186b953cc6ae0f34d258e5 (diff)
downloadaur-0b039e6de711c80e0a71c4933c176eec5abf2777.tar.gz
tizonia-all: updated to track 0.17.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44ecbd7c3fc0..df871d3bc8cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_githubname=tizonia-openmax-il
pkgname=tizonia-all
-pkgver=0.16.0
+pkgver=0.17.0
pkgrel=1
pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Dirble, Plex servers and Chromecast devices."
arch=('x86_64')
@@ -49,9 +49,14 @@ depends=(
'python2-spotipy'
)
source=("${_githubname}-${pkgver}.tar.gz"::"https://github.com/tizonia/${_githubname}/archive/v${pkgver}.tar.gz")
-md5sums=('9c580f2657e24a799483d7082b24fb92')
+md5sums=('8af6ed385f96c76afa99e63d921d0cac')
prepare() {
+ command -v tizonia &> /dev/null \
+ && { \
+ echo >&2 "Please uninstall tizonia-all or tizonia-all-git before proceeding." ; \
+ echo >&2 "See https://github.com/tizonia/tizonia-openmax-il/issues/485." ; \
+ exit 1; }
mkdir -p "$srcdir/path"
# Tizonia expects Python 2
ln -sf /usr/bin/python2 "$srcdir/path/python"