summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuan A. Rubio2020-03-10 00:14:03 +0000
committerJuan A. Rubio2020-03-10 00:14:03 +0000
commit9067499bb40da44bcefcc93139f63808b24535cf (patch)
tree8425f175256d6ab2a3a2e9d69b6cb3878d44cc1e /PKGBUILD
parent0c5a29278834b3660e6c28c22a8586b6435fdc61 (diff)
downloadaur-9067499bb40da44bcefcc93139f63808b24535cf.tar.gz
tizonia-all: updated to track 0.21.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 833af86c7255..1eb909f1553c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_githubname=tizonia-openmax-il
pkgname=tizonia-all
-pkgver=0.19.0
+pkgver=0.21.0
pkgrel=1
-pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Plex servers and Chromecast devices."
+pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, TuneIn, Plex servers and Chromecast devices."
arch=('x86_64')
-url="https://www.tizonia.org"
+url="https://tizonia.org"
license=('LGPL')
depends=(
# official repositories:
@@ -37,6 +37,7 @@ depends=(
'python-eventlet'
'youtube-dl'
'python-levenshtein'
+ 'python-joblib'
# AUR:
'log4c'
@@ -49,7 +50,7 @@ depends=(
'python-spotipy'
)
source=("${_githubname}-${pkgver}.tar.gz"::"https://github.com/tizonia/${_githubname}/archive/v${pkgver}.tar.gz")
-md5sums=('dbe262665e0a4d05f1e25daa6733ca09')
+md5sums=('5380afc416a16e14aa76f6845259813b')
prepare() {
command -v tizonia &> /dev/null \
@@ -62,19 +63,15 @@ prepare() {
build() {
cd "${_githubname}-${pkgver}"
- autoreconf -ifs
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --silent \
- --enable-silent-rules \
- CFLAGS='-O2 -s -DNDEBUG' \
- CXXFLAGS='-O2 -s -DNDEBUG -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security'
- make
+ pwd
+ CFLAGS='-O2 -s -DNDEBUG' \
+ CXXFLAGS='-O2 -s -DNDEBUG -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' \
+ arch-meson build -Dbashcompletiondir=/usr/share/bash-completion/completions -Dzshcompletiondir=/usr/share/zsh/site-functions
+ ninja -C build
}
package() {
cd "${_githubname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+ pwd
+ DESTDIR=$pkgdir ninja -C build install
}