summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Bachmann2016-08-15 22:18:20 +0200
committerSimon Bachmann2016-08-15 22:18:20 +0200
commitdbaa6fe9616dd0fc14b970b1d7ae64f7320d6982 (patch)
tree5654bc6398a343830e7d04c3dd5062015708d5ad /PKGBUILD
downloadaur-tkcon-cvs.tar.gz
Created PKGBUILD. Included a patch for a bug not yet fixed uptstreams
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbfc2b059f9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Simon Bachmann <simonbachmann@bluewin.ch>
+
+pkgname=tkcon-cvs
+pkgver=20160814
+pkgrel=1
+pkgdesc="TkCon is an enhanced interactive console for developing in Tcl."
+url="http://tkcon.sourceforge.net"
+license=('BSD')
+arch=(any)
+depends=('tcl' 'tk')
+makedepends=('cvs')
+conflicts=('tkcon')
+provides=('tkcon')
+source=('under-patch.diff')
+md5sums=('aba22675d6dc3bdc4685f334ef2e7a4d')
+
+_cvsroot=pserver:anonymous@tkcon.cvs.sourceforge.net:/cvsroot/tkcon
+_cvsmod=tkcon
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to $_cvsmod.sourceforge.net CVS server...."
+
+ if [[ -d "$_cvsmod/CVS" ]]; then
+ cd "$_cvsmod"
+ cvs -z3 update -d
+ else
+ cvs -z3 -d:"$_cvsroot" co -D "$pkgver" -f -P "$_cvsmod"
+ cd "$_cvsmod"
+ fi
+
+ msg "CVS checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_cvsmod-build"
+ cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
+ cd "$srcdir/$_cvsmod-build"
+
+ #
+ # patch tkcon.tcl
+ #
+ patch -p1 < "$srcdir/under-patch.diff"
+}
+
+package() {
+ cd "$srcdir/$_cvsmod-build"
+ install -D -m644 -t "${pkgdir}/usr/share/${pkgname}-${pkgver}/docs/" docs/*.html docs/*.txt docs/*.css docs/*.png
+ install -D -m644 docs/license.terms "${pkgdir}/usr/share/licenses/${pkgname}/licensce.terms"
+ install -D -m644 index.html "${pkgdir}/usr/share/${pkgname}-${pkgver}/index.html"
+ install -D -m644 -t "${pkgdir}/usr/share/man/mann/" docs/*.n.man
+ install -D -m644 -t "${pkgdir}/usr/share/man/man1/" docs/*.1.man
+ #install -D -m755 "${srcdir}/tkcon-run.sh ${pkgdir}/usr/bin/tkcon"
+ install -D -m755 tkcon.tcl "${pkgdir}/usr/share/$pkgname-$pkgver/tkcon.tcl"
+ install -d "${pkgdir}/usr/bin/"
+ cd "${pkgdir}/usr/bin/"
+ ln -s "../share/${pkgname}-${pkgver}/tkcon.tcl" "tkcon"
+}
+