summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRuben Agin2023-04-30 04:06:18 -0500
committerRuben Agin2023-04-30 04:06:18 -0500
commit5b58821b7c9371e47e7c6f5c65ce5e84c38280d6 (patch)
treeee619a1b8d36b6145d80fcc77d62a45052893901 /PKGBUILD
parent334b79b2da3822b7edaee69766b2e34992a1aa9b (diff)
downloadaur-5b58821b7c9371e47e7c6f5c65ce5e84c38280d6.tar.gz
Add an external declaration to _tme_scanline_pad in display.c to force non-inlined definition inside of it, per gcc documentation. This should fix NME ticket #47963 hopefully.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c4b02cff566..a5b9f07f343b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,12 @@ sha256sums=('e2c90f7c63de196c7bf52c9b06f17e2ab9db86fa86d8c3ff3ee2360fb20914f8')
options=('libtool')
install=$pkgname.install
+prepare()
+{
+ cd "$pkgname-$pkgver"
+ sed -i '/#include "display.h"/i unsigned int _tme_scanline_pad(int bpl);' host/display/display.c
+}
+
build()
{
cd "$pkgname-$pkgver"