summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralive4ever2016-06-02 10:36:52 +0700
committeralive4ever2016-06-02 10:39:31 +0700
commit647bf5291b337ae2f9b60620c54d1badba8db1b5 (patch)
tree5a73f6796a35809b03e1ee7934269afe330c379b /PKGBUILD
downloadaur-647bf5291b337ae2f9b60620c54d1badba8db1b5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99ffef1c80dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alif <alive4ever at live dot com>
+
+pkgname=tmux-bash-completion
+pkgdesc="Bash completion for tmux"
+pkgver=r6.10eb94a
+pkgrel=1
+arch=("any")
+url="https://github.com/imomaliev/tmux-bash-completion"
+license=("custom")
+makedepends=('git')
+depends=("bash-completion" "tmux")
+source=('git+https://github.com/imomaliev/tmux-bash-completion.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname/completions"
+ for file in tmux tmux1.8; do
+ install -Dm644 $file "$pkgdir/usr/share/bash-completion/completions/$file"
+ done
+}
+