summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122017-08-03 08:56:49 +0200
committerwillemw122017-08-03 08:56:49 +0200
commit3850b0d15bde6066ded8fc0ebe6261eaa8c36fd3 (patch)
tree75ba33977ed0f394d7a59b29290fe32d49f30138 /PKGBUILD
parentf6594cac06758301005680d0d0b771e68aab574d (diff)
downloadaur-3850b0d15bde6066ded8fc0ebe6261eaa8c36fd3.tar.gz
Adopt package
Remove arch=sh4, depends=(gcc-libs). Add provides=, conflicts=.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4975b1f09623..a33bdfb9cf9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: Daniel YC Lin <dlin.tw at gmail>
+# Maintainer: willemw12@gmail.com
+# Contributor: Daniel YC Lin <dlin.tw at gmail>
-pkgname=tmux-mem-cpu-load-git
-pkgver=3.2.1.r4.g557528b
+_pkgname=tmux-mem-cpu-load
+pkgname=$_pkgname-git
+pkgver=3.4.0.r10.g75b9ea7
pkgrel=1
pkgdesc="CPU, RAM memory, and load monitor for use with tmux"
url="https://github.com/thewtex/tmux-mem-cpu-load"
-arch=('i686' 'x86_64' 'sh4')
+arch=('i686' 'x86_64')
license=('APACHE')
-depends=(gcc-libs)
-makedepends=('cmake>=2.6')
-source=('repo::git+https://github.com/thewtex/tmux-mem-cpu-load')
+makedepends=('cmake')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::git+https://github.com/thewtex/tmux-mem-cpu-load)
md5sums=('SKIP')
pkgver() {
- cd repo
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd $pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+
build() {
- cd repo
+ cd $pkgname
cmake .
make
}
+
package() {
- cd repo
- install -Dm755 tmux-mem-cpu-load $pkgdir/usr/bin/tmux-mem-cpu-load
+ cd $pkgname
+ install -Dm755 tmux-mem-cpu-load "$pkgdir/usr/bin/tmux-mem-cpu-load"
}
-# vim:et sw=2 ts=2 ai
+