summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Reimer2019-08-16 20:09:23 +0200
committerManuel Reimer2019-08-16 20:09:23 +0200
commit5112be3ca696edf0aea4b98a13fa850ca9e51b49 (patch)
treeeb9e2d66ed7f8512a047596337ad0085af6ceb49 /PKGBUILD
downloadaur-5112be3ca696edf0aea4b98a13fa850ca9e51b49.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/4d4c2323dc66cf813730d8657bbbdfd9ea5f77c8)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a83fdbc6fb42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Manuel Reimer <manuel.reimer@gmx.de>
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+# Previous Contributor: Baptiste Daroussin <baptiste.daroussin@gmail.com>
+
+pkgname=tnftp6
+pkgver=20151004
+pkgrel=1
+pkgdesc="NetBSD FTP client with several advanced features. Built with IPv6 support."
+arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/"
+license=('BSD')
+depends=('ncurses' 'openssl')
+provides=('tnftp')
+conflicts=('tnftp')
+source=(ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/tnftp-$pkgver.tar.gz)
+md5sums=('a49fbe752318d5a7893f900046ea00d5')
+
+build() {
+ cd "$srcdir/tnftp-$pkgver"
+ ./configure --prefix=/usr --enable-editcomplete --enable-ssl --with-socks=no
+ make
+}
+
+package() {
+ cd "$srcdir/tnftp-$pkgver"
+ make install DESTDIR="$pkgdir"
+ install -Dm755 COPYING "$pkgdir"/usr/share/licenses/${pkgname}/COPYING
+}