summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2015-06-08 23:42:34 +0800
committerwenLiangcan2015-06-08 23:42:34 +0800
commit74b4b4eb775a11616e080f15cad26b03cc904567 (patch)
tree4446f0baf4b0b7de27282b25374fa4f0b942c082 /PKGBUILD
downloadaur-74b4b4eb775a11616e080f15cad26b03cc904567.tar.gz
todo.c-git 20130905-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cdaf205dcf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Contributor: Rafael Beraldo <rafaelluisberaldo@gmail.com>
+
+pkgname=todo.c-git
+pkgver=20130905
+pkgrel=1
+pkgdesc="Command line lightweight todo tool with readable storage , written in C"
+arch=("any")
+url="https://github.com/hit9/todo.c"
+license=('BSD')
+makedepends=('git')
+provides=('todo.c=${pkgver}')
+conflicts=('todo.c' 'todo')
+source=("$pkgname"::'git://github.com/hit9/todo.c.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "src/todo" "$pkgdir/usr/bin/todo"
+ install -Dm644 "LICENSE-BSD" "$pkgdir/usr/share/licenses/todo.c/LICENSE-BSD"
+}